<<

dotfiles

contents

This was last tested in OpenBSD 7.5 and Debian 12.

I keep updated scripts for this here

build procedure

  1. Run through standard install. On OpenBSD, You do want to use X, and you do want to allow xenodm to manage X. Make yourself a user. On Debian, install just the standard system utilities, and sshd.

  2. Log in as your user. su to root.

  3. (OpenBSD) Install curl, git, nano, vmwindowhelper

pkg_add curl nano git vmwh
  1. (Debian) Install curl, git, nano, sudo, xorg, lightdm, xterm
apt install curl nano git sudo xorg lightdm xterm
  1. (OpenBSD) Add your user to doas
echo "permit nopass [username] as root" > /etc/doas.conf
  1. (Debian) Add your user to sudoers
sudoedit /etc/sudoers
  1. (OpenBSD) Install salt-minion
pkg_add salt
  1. (Debian) Install salt-minion
mkdir /etc/apt/keyrings

sudo curl -fsSL -o /etc/apt/keyrings/salt-archive-keyring-2023.gpg \
https://repo.saltproject.io/salt/py3/debian/12/amd64/SALT-PROJECT-GPG-PUBKEY-2023.gpg

echo "deb [signed-by=/etc/apt/keyrings/salt-archive-keyring-2023.gpg \
 arch=amd64] https://repo.saltproject.io/salt/py3/debian/12/amd64/latest \
 bookworm main" | tee /etc/apt/sources.list.d/salt.list

apt update

apt install salt-minion
  1. Head back to your local user
exit
  1. Grab this repo. If you’re going to fork this and make your own dotfiles, you might want to make a step before the cloning bit where you scp your ssh key to the workstation you’re building so you can read/write the repo, and then push your changes back live. If you’re just getting a system running, though, read alone is enough here.
git clone https://github.com/davidemerson/dotfiles.git
  1. (OpenBSD) Execute the execute.sh script, which refreshes the /srv/salt/ directory and applies highstate.
cd dotfiles
chmod 755 execute.sh
doas sh execute.sh
  1. (Debian) Execute the execute.sh script, which refreshes the /srv/salt/ directory and applies highstate.
cd dotfiles
chmod 755 execute.sh
sudo sh execute.sh
  1. Debian only, run fc-cache to update fonts.
fc-cache
  1. Keep salt-minion from starting (unnecessary since we’re using salt-check). Use your editor of choice to comment out the pkg_scripts=salt_minion line in /etc/rc.conf.local.

  2. Make your hostname appropriate by editing /etc/myname with the editor of your choice.

  3. (OpenBSD) Reboot

doas reboot
  1. (Debian) Reboot
sudo reboot

Notes

Additional References

Check out how others have done this kind of thing, for inspiration and documentation:

home | github | mastodon | keyoxide | about

XXIIVV webring